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1. Introduction 

VIVE Wave runtime had already supported OpenXR standard on VIVE Focus3. 

Welcome to join OpenXR of Wave runtime. 

 

Since Unreal Engine 4.27, Epic Games claimed that the OpenXR Plug-in which 

allowed to develop the cross-platform applications for OpenXR is Production-Ready. 

In this guide, you will learn how to build an OpenXR app running on Focus3 through 

the following step-by-step sections.  

 

What you will learn in this guide: 

 Download pre-built Unreal Engine 4.27 / 5.0 through Epic Games Launcher 

 Package, install and run Wave OpenXR application on VIVE Focus3 

 Porting scene to use Wave OpenXR 

 

What Wave support on Focus3 in this release version: 

 HMD tracking pose and XR rendering 

 Controller tracking pose, key input, and haptics 

 Hand tracking pose and Hand Interaction 

 Wrist Tracker 

 

Okay. Let’s get started to create your VIVE Wave OpenXR content on Focus3! 
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2. Download Pre-built Unreal Engine 

2.1 Download Epic Games Launcher. 

Download Epic Games Launcher here. 

  

2.2 Download Unreal Engine by Epic Games Launcher 

Navigate to Unreal Engine > Library and add ENGINE VERSIONS 4.27.2 or 5.0.2. 

 

  

https://www.epicgames.com/store/en-US/download


 
 

 
7 

HTC PROPRIETARY & CONFIDENTIAL. DO NOT DUPLICATE OR DISTRIBUTE 
WITHOUT PERMISSION. 

3 Wave OpenXR SDK 

3.1 Wave OpenXR Plug-In 

The Wave OpenXR Plug-In is at <Where you unzip 

wave_openxr_unreal_plugin_<version>.zip>\WaveOpenXR. 

3.2 How to import Wave OpenXR Plug-In 

Steps: 

1. Copy and paste WaveOpenXR to <Your Project Folder>\Plugins\ such as 

<Your Project Folder>\Plugins\WaveOpenXR (Create a directory named 

“Plugins” if the project doesn’t have.) 

2. Double-click <Your project>.uproject to launch the project. 

Then click Unreal Engine Editor > Edit > Plugins, the WaveOpenXR should be in 

the category Project > VirtualReality. Please relaunch the editor if the 

WaveOpenXR Plug-In did not include in the Plugins list. 

 

3.3 OpenXRSample 

OpenXRSample is a sample project which includes scenes which let you 

experience our features such as input, hand tracking or other advanced features. 

Unzip wave_openxr_unreal_sample_<version>.zip to get it. Please note that, you 

should import Wave OpenXR Plug-In before packaging the android apps. 
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4 Package the Android Sample 

Please make sure you already import the WaveOpen XR Plug-In. Then launch 

OpenXRSample\OpenXRSample.uproject. 

 

4.1 Project Settings of Android Environments 

Click Edit > Project Settings to open the Project Settings window and navigate to 

Platforms > Android SDK. 

 

You could refer Setting up Android SDK and NDK for Unreal to set up. 

4.1.1  Location of Android SDK 

Download Android Studio if you didn’t have yet. In Android Studio Editor, click 

Tools > SDK Manager and navigate to Appearance & Behavior > System Settings > 

Android SDK. The Android SDK Location is the path to be filled. 

https://docs.unrealengine.com/4.27/en-US/SharingAndReleasing/Mobile/Android/Setup/AndroidStudio/
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4.1.2  Location of Android NDK 

Please fill your Android NDK(21.1.6352462) path to it. The NDK could be 

downloaded in the Android SDK. Click the tab SDK Tools and select Show Package 

Details at bottom right of the page to see the options. 
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4.1.3  Location of JAVA 

It is recommended to install jdk1.8.0. 

  

https://www.oracle.com/java/technologies/javase/javase8-archive-downloads.html
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4.2 Package the ButtonTest to an Android APK 

You will see the current level is ButtonTest which is located at Content > 

ButtonTest > ButtonTest.umap. 

 

In UE4.27, click File > Package Project > Android > Android(ASTC) to package the 

android application. In UE5.0, click icon Platforms > Android > Package Project to 

package it. 

 

Then you will see the OpenXRSample-arm64.apk in the path <path to 

OpenXRSample>/Android_ASTC/. 

Then you can execute Install_OpenXRSample-arm64.bat to install the android 

application automatically. For more information, refer to Android Getting Started. 

Launch the sample OpenXRSample in Focus3, you can use right controller to 

control right objects and left controller to control left objects. 

The far cube presents the button “touch” and “axis” actions. The far cube will 

change color when touching a button and rotate when the button has axis. Only 

Trigger and Grip button have axis. 

The near cube presents the button “press” action and will change color when 

pressing a button. 

The cone presents the Thumbstick axis and will move when you operate the 

Thumbstick button. 

  

https://docs.unrealengine.com/4.27/en-US/SharingAndReleasing/Mobile/Android/GettingStarted/
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5 Porting scene to use Wave OpenXR 

Unreal offered a Virtual Reality template project for starter. You can migrate your 

scene to the project and refer the video below to get started. 

In UE4.27, select Virtual Reality project in the template list. 

 

In UE5.0, click GAMES then select Virtual Reality project. 

 

Creating AR and VR Projects with Unreal Engine | Webinar 

https://www.youtube.com/watch?v=Asw4C51RH9I
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5.1  Import Wave OpenXR Plug-In 

Please refer chapter 3.2 above to see how to import the Wave OpenXR Plug-In.   

5.2  Disable other Virtual Reality Plugin-Ins 

Please keep Oculus OpenXR, Oculus VR and SteamVR disabled and keep OpenXR, 

OpenXREyeTracker, OpenXRHandTracking, WaveOpenXR enabled. 

5.3 Project Settings 

5.3.1  Project Settings of Unreal Engine 

We assumed you migrate your scene to Virtual Reality project which Epic Games 

offered. You can refer other settings in Virtual Reality project that we didn’t 

mention below. 

Enable Support arm64 and disable Support armv7. (Skip this in UE5 because UE5 

did not support armv7 anymore.) 
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Enable Support Vulkan. (MUST) 

 

Disable Show launch image to get rid of the non-stereo splash while launching 

app. 

 

5.3.2  Project Settings of WaveOpenXR Plug-In 

Click Edit > Project Settings to open the Project Settings window and navigate to 

Plugins > VIVE Wave OpenXR - Android. 

  

5.3.2.1 Enable Hand Interaction 

Select this option to enable Hand Interaction feature. For more information, see 

chapter 6.2. 
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5.3.2.2 Enable Wrist Tracker 

Select this option to enable Wrist Tracker feature. For more information, see 

chapter 6.3. 

5.3.2.3 Enable Focus3 Controller 

Select this option to support Focus3 controller. 

5.4 Input 

To use the Focus3 controller input, you have to apply the Input action and axis 

mappings. Refer to this guide for detailed information. 

Go to Project Settings > Engine > Input to configure the Action Mappings and 

Axis Mappings. You can see the inputs of VIVE Focus3 by typing “Focus3” in the 

action specifying window. 

 

https://www.unrealengine.com/en-US/blog/input-action-and-axis-mappings-in-ue4?sessionInvalidated=true
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Note: you have to enable the Auto Receive Input option in your blueprints to 

retrieve inputs. 
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6 Advanced Features 

6.1 Hand Tracking 

 

Please make sure the OpenXRHandTracking is enabled and refer to 

OpenXRSample/Content/NaturalHand/NaturalHand.umap 

6.2 Hand Interaction 

Use pinch motion to interact with Actors. 

6.2.1 Project Setting 

 

Click Edit > Project Settings to open the Project Settings window and navigate to 

Plugins > VIVE Wave OpenXR - Android. Select Enable Hand Interaction to enable 

this feature. 



 
 

 
18 

HTC PROPRIETARY & CONFIDENTIAL. DO NOT DUPLICATE OR DISTRIBUTE 
WITHOUT PERMISSION. 

6.2.2 Blueprint Function Libraries 

 

You can retrieve these pinch status of left hand if Is Left is true and the status of 

right hand if Is Left is false. 

6.2.2.1 Get Pinch Active 

 

Checks if the pinch motion is active. 

6.2.2.2 Get Pinch Tracked 

 

Checks if the pinch motion is tracked. 

6.2.2.3 Get Pinch Position 

 

Retrieves the position of pinch origin of left or right hand. 
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6.2.2.4 Get Pinch Rotation 

 

Retrieves the rotation of pinch origin of left or right hand. 

6.2.2.5 Get Pinch Strength 

 

Retrieves the pinch strength of left or right hand. The return value should be [0, 

1]. 1 means the index finger is closed to thumb very much. 

6.2.3 Wave OpenXR Hand Pointer 

Wave OpenXR Hand Pointer is a SceneComponent which use the Hand Interaction 

feature. Wave OpenXR Hand Pointer make you easy to interact with Actors by 

hand. 

  

The detail of WaveOpenXRHandPointer: 
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Please refer OpenXRSample/Content/NaturalHand/NaturalHand.umap to see the 

sample. 

6.3 Wrist Tracker 

Retrieve the status of Wrist Tracker. 
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6.3.1 Project Settings 

 

Click Edit > Project Settings to open the Project Settings window and navigate to 

Plugins > VIVE Wave OpenXR - Android. Select Enable Wrist Tracker to enable 

this feature. 

6.3.2 Blueprint Function Libraries 

 

You can retrieve these tracker status of left or right device by setting Is Left. The L 

/ R light mark the device is left or right. The L light will be on if the tracker is the 

left device. 

6.3.2.1 Get Tracker Active 

 

Checks if the tracker is active. (The device is connected or not.) 
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6.3.2.2 Get Tracker Tracked 

 

Checks if the tracker is tracked. 

6.3.2.3 Get Tracker Position 

 

Retrieves the position of the left or right tracker. 

6.3.2.4 Get Tracker Rotation 

 

Retrieves the rotation of the left or right tracker. 

6.3.2.5 Get Tracker Key Down 

 

There are two buttons for each tracker. They are Menu and Primary. 

Checks if these buttons pressing or not (releasing). 
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Note: You cannot retrieve the key status of Menu on the right device since it’s a 

reserved key. 

6.3.3 Key event of Tracker input 

The Get Tracker Key Down Blueprint Function is a polling way to get key status. If 

you want to listen one key event when the button had been pressed or released. 

You can register your input action event and add Tracker inputs in it: 

Click Edit > Project Settings to open the Project Settings window and navigate to 

Engine > Input. 

There are four inputs belongs to tracker, two for each tracker: 

 Tracker (L) Menu, Tracker (L) X Press, Tracker (R) System and Tracker (R) A 

Press. 

Note: You cannot retrieve the Tracker (R) System key status since it’s a reserved 

key. 

For example, I register the Input Action TriggerRight and add the Tracker (R) A 

Press in it, then I can listen the key event by InputAction TriggerRight. 
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For more information, refer to InteractiveExperiences-Input. 

https://docs.unrealengine.com/4.27/en-US/InteractiveExperiences/Input/
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7 Known Issues 

None. 
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8 Troubleshooting 

8.1 Apps with development build may crash after turning off 
HMD by pressing power bank or take off for a while and put 
it on. 

[How to fix] Select project settings > Project > Packaging > Project > Build 

Configuration as Shipping. 

8.2 [UE5][HandTracking][ShippingBuild] The Actor may 
disappear when you convert Hand Key Rotation (Quat) to 
Rotator and set the rotation to the Actor. 

 

[How to fix] Make sure the Quat IsNormalized(Quat) first. 
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